The Forestry Forum is sponsored in part by:

Forestry Forum
Sponsored by:

TimberKing Sawmills

Toll Free 1-800-582-0470

LogRite Tools

Norwood Industries Inc.

Sawmill & Woodlot Magazine

Your source for Portable Sawmills, Edgers, Resaws, Sharpeners, Setters, Bandsaw Blades and Sawmill Parts

EZ Boardwalk Sawmills. More Saw For Less Money! sponsored by Northeast STIHL

Woodland Sawmills

Peterson Swingmills

 KASCO SharpTech WoodMaxx Blades


Sawmill Exchange

BRUTE FORCE Authorized Dealer

Woodshax Outdoor Vending Solutions


Council Tool

Baker Products



Author Topic: 548GIII  (Read 603 times)

0 Members and 1 Guest are viewing this topic.

Offline Nemologger

  • Senior Member
  • ****
  • Posts: 291
  • Age: 57
  • Location: Northeast Missouri
  • Gender: Male
    • Share Post
« on: November 23, 2017, 08:13:55 PM »
On my 548GIII there is times when I start it and it will suddenly go to half throttle. If I shut it off and re start some times it will do it again or sometimes it will be ok. I think it has to do with the switch on the dash that is the throttle control . Is there a Selenoid or something that could be bad? It will only do this if the machine has sit a few days.
Clean and Sober

Offline OH logger

  • Senior Member
  • ****
  • Posts: 547
  • Location: NW OHIO
  • Gender: Male
  • livin the dream
    • Share Post
Re: 548GIII
« Reply #1 on: November 23, 2017, 09:19:54 PM »
I assume it revs higher than the preset warm up idle?? if so I think your on the right track thinkin about the throttle speed switch on the dash. that's where id start if mine did that. pull that fuse out if it has one (I think it does) and put it or a new one back in. that's about the extent of my electric fixing abilities!!  ;D

Offline Gearbox

  • Senior Member x2
  • *****
  • Posts: 1184
  • Age: 72
  • Location: North MN
  • Gender: Male
    • Share Post
Re: 548GIII
« Reply #2 on: November 23, 2017, 09:21:07 PM »
Could it be a low voltage thing ? Take a meter reading on each battery unhooked cold befor starting after sitting for a couple days . Newer stuff does not like low voltage .
A bunch of chainsaws a BT6870 processer , TC 5 International track skidder and not near enough time

Offline kiko

  • Senior Member
  • ****
  • Posts: 678
  • Location: Middle Georgia
    • Share Post
Re: 548GIII
« Reply #3 on: November 24, 2017, 12:26:34 AM »
I have little experienced with 548g3.    6 and 7 yes.  On all but the early g3s the foot feed has a potentiometer on it.   The rubber boot below the pedal will get a hole in it and let dirt collect down in there where the potentiometer is.   Could be hanging up or the potentiometer it self could be bad.  There were two styles of the electric foot feed if I recall correctly.

Offline Firewoodjoe

  • Senior Member
  • ****
  • Posts: 643
  • Age: 30
  • Location: Northern lower michigan
  • Gender: Male
  • I'm new!
    • Share Post
Re: 548GIII
« Reply #4 on: November 24, 2017, 06:09:49 AM »
I know on the 648s (boss has 3) that foot pedal control has been a common problem. But I've never had one rev up only not work when u push the pedal.

Offline finding the trail

  • member
  • *
  • Posts: 41
  • Location: ny
  • Gender: Male
  • I'm new!
    • Share Post
Re: 548GIII
« Reply #5 on: November 29, 2017, 06:04:24 PM »
  It may be part of the warm up. My machines run at 1050 rpm's at startup after a minute or two they idle down. They have done this from day one.

Share via delicious Share via digg Share via facebook Share via linkedin Share via pinterest Share via reddit Share via stumble Share via tumblr Share via twitter

My new to me 548gIII

Started by Nemologger on Forestry and Logging

12 Replies
Last post December 22, 2014, 06:41:01 PM
by wannaergo
Vent on 548gIII

Started by Nemologger on Forestry and Logging

3 Replies
Last post December 23, 2014, 10:13:45 AM
by Gadrock

Powered by EzPortal