The Forestry Forum is sponsored in part by:

iDRY Vacuum Kilns


Forestry Forum
Sponsored by:


TimberKing Sawmills



Toll Free 1-800-582-0470

LogRite Tools



Norwood Industries Inc.




Your source for Portable Sawmills, Edgers, Resaws, Sharpeners, Setters, Bandsaw Blades and Sawmill Parts

EZ Boardwalk Sawmills. More Saw For Less Money!

STIHLDealers.com sponsored by Northeast STIHL


Woodland Sawmills

Peterson Swingmills

 KASCO SharpTech WoodMaxx Blades

Turbosawmill

Sawmill Exchange

Michigan Firewood, your BRUTE FORCE Authorized Dealer

Baker Products

ECHO-Bearcat

iDRY Wood Lumber Vacuum Drying for everyon

Nyle Kiln Dry Systems

Chainsawr, The Worlds Largest Inventory of Chainsaw Parts

Smith Sawmill Service



Author Topic: Morbark/Eeger Beever Chipper feed pressure issue  (Read 197 times)

0 Members and 1 Guest are viewing this topic.

Offline logdog664

  • member
  • *
  • Posts: 2
  • Age: 29
  • Location: Hubbardston, MA
  • Gender: Male
  • Attitude is everything, pick a good one.
    • Share Post
Morbark/Eeger Beever Chipper feed pressure issue
« on: April 18, 2021, 08:33:42 PM »
Anyone use an older morbark 290 or eeger beever disk chipper with the two feed motors, and experience the bottom roller go faster and top roller stop when you put a large piece in? There is a pressure issue somewhere. The manual says its the feed motor itself, or the valve.  Ive already checked the obvious things like oil level (did filter and hyd oil change), i think the pump is working fine because the pressure in reverse is good.  Forward feed pressure on the top roller is the only thing going wrong.  Engine rpm does not seem to be the issue either.  Any input would be greatly appreciated. Anyone know if the directional valve has a pressure adjustment for each roller?
Clark 664B, ASV RS-75 /w Brushmonster Mower, Martatch Grapple, Halverson Firewood Processor, Morbark 290, Jonsered 2050,625,630,670,2166, Stihl 660

Offline mike_belben

  • Senior Member x2
  • *****
  • Posts: 10603
  • Location: Middle TN
  • Pulp Friction
    • Share Post
Re: Morbark/Eeger Beever Chipper feed pressure issue
« Reply #1 on: April 18, 2021, 09:45:04 PM »
if both top and bottom motors are wired in series.. [that is: hose comes out of valve into first motor, hose comes out of first motor into second motor, hose comes out of second motor back to valve or back to tank] ...and if the first or both motors have case drains [ a 3rd hose on each motor] then leakage in the first motor would take the case drain back to tank and bypass the 2nd motor.  


this would likely give the result you have.. a speed mismatch where the first motor to get the flow runs faster than the 2nd because a bunch of it is being short circuited ahead of the 2nd motor via the case drain leak.  if you have a case drain line you could plug it temporarily to see if the 2nd motor comes back to life.  this is NOT a fix,, its a brief test.  

i would pull the motors and tear them both down on a video recording for reassembly.. to see whats wrong internally.  should be easy to spot. 
Isaiah 48:10


Share via delicious Share via digg Share via facebook Share via linkedin Share via pinterest Share via reddit Share via stumble Share via tumblr Share via twitter

xx
Morbark 16 chipper ???

Started by BargeMonkey on Forestry and Logging

6 Replies
2300 Views
Last post December 23, 2017, 07:19:50 AM
by loggah
xx
Morbark #5 Chipper

Started by fullchoke on Forestry and Logging

4 Replies
397 Views
Last post March 11, 2021, 12:58:22 AM
by fullchoke
xx
Morbark chipper question

Started by treecare on Forestry and Logging

11 Replies
4001 Views
Last post September 17, 2012, 04:26:01 AM
by amberwood
xx
Morbark model 16 chipper

Started by logger444 on Forestry and Logging

1 Replies
2726 Views
Last post June 29, 2009, 05:52:42 PM
by nhlogga
 


Powered by EzPortal