Forum > Lucas Mill

Lucas 827 not starting

(1/1)

Runningalucas:
Greetings,

I've got my mill set up for the Summer.  I did a bad thing according to Lucas, but didn't realize till after the fact.  They state not to jump start your mill, as doing so 'will' mess up the electronics.  My battery which was on a tender through the winter, after charging up tested, 'good', but once in the mill it wouldn't do anything.  I attached another battery via some very long 14 gauge wires that I've got set up with alligator clips for something else.  This resulted in only slightly bumping the engine. 

Knowing it was a bad battery(tested good..tester is from China lol), I bought a new one, cranked the machine over, and still no start.  I used a little ether, and it fired right up.  The machine idled normally, and did so for a number of minutes.  After that, I cranked the machine up to full throttle, and had no problem there; backed it down to an idle, and let it run there for a few more minutes, then shut the machine off.

Next up, after about 20 minutes with farting around with some other stuff, I tried starting it again; no fire.  I used a more ether, and squirted a few times.  It should've fired off even without gas; I'd think?! 

Next up, I pulled both spark plugs, hooked each up to their wires, and held them against the frame, it was bright daylight, but I didn't see a spark. 

Any ideas, or does anyone know where I can find a decent manual online for the Kohler 27?

Thanks In Advance,

Matt

Runningalucas:
I got a response from Lucas, I must be getting old, as I forgot about the limit switch on the saw guard.... which was the problem.

Navigation

[0] Message Index

Go to full version
Sitemap